home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-perl / Net-SSLeay-1.25 / Net-SSLeay-1.25.ebuild < prev    next >
Encoding:
Text File  |  2006-05-02  |  836 b   |  31 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-SSLeay/Net-SSLeay-1.25.ebuild,v 1.12 2006/04/09 17:27:03 flameeyes Exp $
  4.  
  5. inherit perl-module multilib
  6.  
  7. MY_P=${PN/-/_}.pm-${PV}
  8. S=${WORKDIR}/${MY_P}
  9. DESCRIPTION="Net::SSLeay module for perl"
  10. HOMEPAGE="http://www.cpan.org/authors/id/SAMPO/${MY_P}.readme"
  11. SRC_URI="mirror://cpan/authors/id/SAMPO/${MY_P}.tar.gz"
  12.  
  13. LICENSE="|| ( Artistic GPL-2 )"
  14. SLOT="0"
  15. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
  16. IUSE=""
  17.  
  18. DEPEND="dev-libs/openssl"
  19.  
  20. export OPTIMIZE="$CFLAGS"
  21.  
  22. myconf="${myconf} /usr"
  23.  
  24. src_unpack() {
  25.     unpack ${A}
  26.     if [ $(get_libdir) != "lib" ] ; then
  27.         sed -i -e "s:openssl_path/lib:openssl_path/$(get_libdir):" \
  28.         ${S}/Makefile.PL || die
  29.     fi
  30. }
  31.